Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 16 Jun 2015 14:04:04 -0400
From: Mathieu Laprise <mathlaprise@...il.com>
To: john-users@...ts.openwall.com
Subject: Re: [Johnny-RFC] Which Qt min version to require ?

On Tue, Jun 16, 2015 at 1:25 PM, Solar Designer <solar@...nwall.com> wrote:

> Both, but I didn't check Distrowatch until now.  Here's SL6:
>
> [solar@...er ~]$ rpm -qa|fgrep -w qt
> qt-sqlite-4.6.2-26.el6_4.x86_64
> qt-devel-4.6.2-26.el6_4.x86_64
> qt-4.6.2-26.el6_4.x86_64
> qt-x11-4.6.2-26.el6_4.x86_64
>
> Also, Distrowatch lists 4.8.5 for RHEL7, so even if we chose not to
> support RHEL6, we can't go higher than Qt 4.8.5 anyway.
>
> It is important for us to support RHEL (and clones), and it's preferable
> that we include support for RHEL6 rather than require RHEL7.
>
Okay, I'll compile qt 4.6.2 for my system and compile latest johnny with
it. I'll see if it builds, see how many conflicts we have and try to fix
them while testing.

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.