Date: Mon, 23 Jul 2012 18:10:25 +0200 From: Frank Dittrich <frank_dittrich@...mail.com> To: john-dev@...ts.openwall.com Subject: Re: Some more external mode definitions On 07/23/2012 05:11 PM, magnum wrote: > On 2012-07-23 15:14, Frank Dittrich wrote: >> I prepared a patch to rename maxlen to cipher_limit, because that is the >> name that has a better chance to be accepted for core jumbo. > > This is marginally useful as we're not sure cipher_limit will be the > final name anyway. When Solar changes core, I'll probably need to sort > things out no matter what we call it. But sure, go ahead. If we release a jumbo version with a name that differs, then users must change the external modes they defined on their own if we later change the name. If the implementation changes in core, that's not a problem, because that is not part of the "user interface". >> Since I prefer not to push changes into your repository without a chance >> for others to review them, I'll include the patch inlined at the end of >> my mail. > > You wont push directly anyway. When you send a pull request, the one > accepting it (usually me or Dhiru) can/should review it. Having said > that, it's not a bad idea to show it here too. I know I don't push into your repository. and this was a trivial change anyway. But generally, I'd prefer comments and suggestions prior to changes being published in your repository and pulled by others. May be I shouldn't care about that. I just sent a pull request for this change + (in a separate commit) the filter_rot13 rewritten for easier adjustment (rot1 ... rot25?) Frank
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.