Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 13 Jul 2011 14:02:44 +0200
From: Luka Marčetić <>
Subject: Re: cluts review

On 07/13/2011 01:07 PM, Solar Designer wrote [...]

Hmm, hope you won't mind me saying: Diff output for multiple files 
replacing 1-2 non-subsequent lines is not very readable. Anyway, I'll 
add _POSIX_SOURCE for sigaction and replace SA_NODEFER with 0 (I'm sure 
it served its purpose *somewhere* :-/). Not sure why _BSD_SOURCE is 
needed for alphasort, but I see from the man it is (I usually look up 
functions from SUSv4), so I'll add that too. Instead of <sys/param.h> 
for PATH_MAX, will limits.h do (that's what i usually include)?

> As it is, this patch is a hack.  I think that extensive cleanups to the
> code being patched are needed.

As I've announced, alloc.c is going to be rewritten: As Rich suggested 
to me, it'll use arrays instead of lists which will speed up things and 
make them prettier.. actually I think it's in alloc.c's TODO. String.c 
will also be rewritten, because, as I've said, it's impractical to write 
so much code for a few tests (not sure yet how exactly). If there are 
any other critiques, I would like to hear them.

> I have other observations as well (such as from actually running the
> tests), which I hope to post separately.

Ok. I only hope it's understood that I've made the tests report failures 
alone. It would serve no purpose to output success messages (eg. 
numeric.c would report a *lot* of things). If that's not what you meant, 
shoot, I'm listening.

Powered by blists - more mailing lists

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.