Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Wed, 08 Feb 2017 16:48:10 -0500
From: valdis.kletnieks@...edu
To: Kees Cook <keescook@...omium.org>
Cc: kernel-hardening@...ts.openwall.com, linux-kernel@...r.kernel.org
Subject: next-20170207 initify_plugin kills gcc7.

Seen in next-20170207:

[/usr/src/linux-next] gcc --version
gcc (GCC) 7.0.1 20170204 (Red Hat 7.0.1-0.6)
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

[/usr/src/linux-next] make drivers/acpi/acpica/utdebug.o
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     include/generated/timeconst.h
  CHK     include/generated/bounds.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  DESCEND  objtool
  CC      drivers/acpi/acpica/utdebug.o
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_TYPE               | structleak_plugin
PLUGIN_ATTRIBUTES                | latent_entropy_plugin structleak_plugin initify_plugin
PLUGIN_START_UNIT                | latent_entropy_plugin initify_plugin
drivers/acpi/acpica/utdebug.c: In function ?acpi_debug_print?:
drivers/acpi/acpica/utdebug.c:158:1: internal compiler error: in is_call_arg_nocapture, at scripts/gcc-plugins/initify_plugin.c:792
 acpi_debug_print(u32 requested_debug_level,
 ^~~~~~~~~~~~~~~~
0x7f253a2b2127 is_call_arg_nocapture
	scripts/gcc-plugins/initify_plugin.c:792
0x7f253a2b2af8 search_capture_use
	scripts/gcc-plugins/initify_plugin.c:1054
0x7f253a2b2af8 has_capture_use_local_var
	scripts/gcc-plugins/initify_plugin.c:1140
0x7f253a2b349f verify_nocapture_functions
	scripts/gcc-plugins/initify_plugin.c:1477
0x7f253a2b349f initify_function_transform
	scripts/gcc-plugins/initify_plugin.c:1485
Please submit a full bug report,
with preprocessed source if appropriate.
Please include the complete backtrace with any bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[1]: *** [scripts/Makefile.build:295: drivers/acpi/acpica/utdebug.o] Error 1
make: *** [Makefile:1640: drivers/acpi/acpica/utdebug.o] Error 2
[/usr/src/linux-next]


Content of type "application/pgp-signature" skipped

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.