Date: Wed, 25 Jan 2017 14:51:24 +0100 From: Pavel Machek <pavel@....cz> To: Laura Abbott <labbott@...hat.com> Cc: Kees Cook <keescook@...omium.org>, Jason Wessel <jason.wessel@...driver.com>, Jonathan Corbet <corbet@....net>, Russell King <linux@...linux.org.uk>, Catalin Marinas <catalin.marinas@....com>, Will Deacon <will.deacon@....com>, "James E.J. Bottomley" <jejb@...isc-linux.org>, Helge Deller <deller@....de>, Martin Schwidefsky <schwidefsky@...ibm.com>, Heiko Carstens <heiko.carstens@...ibm.com>, Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>, "H. Peter Anvin" <hpa@...or.com>, x86@...nel.org, Rob Herring <robh@...nel.org>, "Rafael J. Wysocki" <rjw@...ysocki.net>, Len Brown <len.brown@...el.com>, Mark Rutland <mark.rutland@....com>, Jessica Yu <jeyu@...hat.com>, linux-doc@...r.kernel.org, linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org, linux-parisc@...r.kernel.org, linux-s390@...r.kernel.org, linux-pm@...r.kernel.org, kernel-hardening@...ts.openwall.com Subject: Re: [PATCH 1/2] security: Change name of CONFIG_DEBUG_RODATA On Wed 2017-01-25 12:21:05, Laura Abbott wrote: > On 01/19/2017 08:53 AM, Pavel Machek wrote: > >On Wed 2017-01-18 17:29:05, Laura Abbott wrote: > >> > >>Despite the word 'debug' in CONFIG_DEBUG_RODATA, this kernel option > >>provides key security features that are to be expected on a modern > >>system. Change the name to CONFIG_HARDENED_PAGE_MAPPINGS which more > >>accurately describes what this option is intended to do. > > > >I think this is bad change. CONFIG_DEBUG_RODATA is describing what it > >does, CONFIG_HARDENED_PAGE_MAPPINGS is advertising. > > > >We don't do advertising, and we don't force people to re-answer the > >config questions without good reason. > > > >CONFIG_HARDENED_RODATA might fix the first problem, but not the second > >one. > > > > Pavel > > > > (Apologies, my SMTP was set up incorrectly so my response didn't > actually get sent out) > > CONFIG_DEBUG_RODATA isn't describing what it does though. It misses > that this config may handle much more than just rodata. I think > Mark Rutland's suggestion of STRICT_KERNEL_RWX might be more > descriptive. CONFIG_BUG=y CONFIG_LBDAF=y CONFIG_PM_OPP=y ..it is config option. It is not description of the feature. People are living with that config option for a while. I'd keep it. Maybe you can go from CONFIG_DEBUG_RODATA to CONFIG_RODATA... (but you'll still have people re-answer config option.) Pavel -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html Download attachment "signature.asc" of type "application/pgp-signature" (182 bytes)
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.