Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 16 Jun 2015 18:24:47 +0300
From: Solar Designer <>
Subject: Re: [Johnny-RFC] Which Qt min version to require ?

On Mon, Jun 15, 2015 at 08:17:11PM -0400, Mathieu Laprise wrote:
> New qt versions sometimes add new functions which will prevent building
> latest Johnny on old versions like 4.8 for example. I guess it might also
> prevent running a distributed dynamically-linked executable requiring a
> function from qt 5.1 on old linux distros with qt 4.8 for example if it
> hasn't been updated for a long time (example: fedora 19 without update).
> Here is a short history of qt release date.
> Qt 4.8 was released in december 2011
> Qt 5.0 was released in december 2012
> Qt 5.1 was released in december 2013
> ...
> Qt 5.4 was released in december 2014
> We are asking our users this simple question : do you use outdated linux
> distros (from example 2013 or older) with old version of Qt such as below
> 5.1 ?

Yes!  You won't like this, but I'd prefer Johnny to work on RHEL6 /
CentOS 6 / Scientific Linux 6, and this means Qt 4.6.2.

Also, I'd prefer Johnny to work on Mac OS X Leopard aka 10.5, and up.

Sorry for making life difficult to you.


Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.