Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 16 Jun 2015 17:12:15 +0300
From: Shinnok <>
Subject: Re: [Johnny-RFC] Which Qt min version to require ?

> On Jun 16, 2015, at 3:17 AM, Mathieu Laprise <> wrote:
> New qt versions sometimes add new functions which will prevent building
> latest Johnny on old versions like 4.8 for example. I guess it might also
> prevent running a distributed dynamically-linked executable requiring a
> function from qt 5.1 on old linux distros with qt 4.8 for example if it
> hasn't been updated for a long time (example: fedora 19 without update).
> Here is a short history of qt release date.
> Qt 4.8 was released in december 2011
> Qt 5.0 was released in december 2012
> Qt 5.1 was released in december 2013
> ...
> Qt 5.4 was released in december 2014
> We are asking our users this simple question : do you use outdated linux
> distros (from example 2013 or older) with old version of Qt such as below
> 5.1 ?
> If this is important to ours users, we might still support Qt >=4.8(or 5.1)
> by making sure to not use latest API changes. We don't use a lot of new
> functions and for those that we use, we could investigate on making
> workaround(s) to avoid using them. But is it worth it, are you people still
> using those qt versions on your distros ?
> Thanks for your feedback!

It's important to notice that this question mostly pertains to Linux/BSD distros. It would be helpful if you could follow back with a list of what versions of Qt5 SDK's are found in the latest stable versions of the distros with the widest usage on desktops.


Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.