Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 30 Jul 2011 12:33:42 -0500
From: "JimF" <jfoug@....net>
To: <john-users@...ts.openwall.com>
Subject: Re: Compiling john 1.7.8 jumbo under Windows XP+cygwin

----- Original Message ----- 
From: "Solar Designer" <solar@...nwall.com>
> On Sat, Jul 30, 2011 at 11:45:29AM -0400, madfran wrote:
>> I am trying to compile the jumbo release of john 1.7.8 under XP (with 
>> patch
>
> It looks like your libssl is linked with libz, so you need to add -lz to
> LDFLAGS.  Does this help?
>
> If so, I wonder why others are apparently not experiencing the same
> problem with builds on Cygwin.

I have not seen this issue on my builds. I only use Cygwin now, since MinGW 
support has been DOA since 1.7.8 jumbo-x.  But I use the Makefile as it 
exists in the current jumbo-4 (with my changes for 'build-type'), and it 
works fine.  I have made no changes to any of the LDFLAGS.

madfran, are you using the win32-cygwin-x86-sse2 and not the 
win32-mingw-x86-sse2 build rules?  They both are likely to succeed on a 
cygwin installation, but the 2nd is less likely to be as robust and up to 
date.

Jim. 

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.