Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 30 Sep 2009 04:19:43 +0400
From: Solar Designer <solar@...nwall.com>
To: owl-users@...ts.openwall.com
Subject: Re: CentOS packages

On Tue, Sep 29, 2009 at 05:58:17PM +0400, croco@...nwall.com wrote:
> On Tue, Sep 29, 2009 at 12:57:57AM +0400, Solar Designer wrote:
> > 
> > You can try CentOS 4 packages.  I'd be curious to know if they install
> > and work on Owl-current. 
> 
> JFYI, it seems to be impossible to install their httpd package in Owl.

You mean specifically Owl-current.  The db4 version changed between
2.0-stable and current.  This is why I wrote "I'd be curious" - thank
you for satisfying my curiosity.  We may in fact downgrade db4 in
2.1-stable prior to 2.1-release for this reason (to restore RHEL4
compatibility).

> Trying to meet the dependencies (downloading the appropriate RPMs, guessing
> what's where etc) I ended up with the following command:
> 
> rpm -Uvh httpd-2.0.52-41.ent.4.centos4.i386.rpm
> httpd-suexec-2.0.52-41.ent.4.centos4.i386.rpm db4-4.2.52-7.3.el4.i386.rpm
> expat-1.95.7-4.i386.rpm apr-0.9.4-24.9.i386.rpm
> apr-util-0.9.4-22.el4.i386.rpm libgssapi-0.8-1.i386.rpm
> krb5-libs-1.3.4-62.el4.i386.rpm openldap-2.2.13-12.el4.i386.rpm
> cyrus-sasl-2.1.19-14.i386.rpm cyrus-sasl-md5-2.1.19-14.i386.rpm
> 
> As such it says:
> 
> 
> error: Failed dependencies:
>         /etc/mime.types is needed by httpd-2.0.52-41.ent.4.centos4
>         libdb-4.3.so is needed by (installed) db4-utils-4.3.29-owl5
>         libdb-4.3.so is needed by (installed) pam-1.1.0-owl1
>         libdb-4.3.so is needed by (installed) perl-5.8.8-owl5
>         libdb-4.3.so is needed by (installed) postfix-2.4.13-owl1
>         db4 = 4.3.29-owl5 is needed by (installed) db4-devel-4.3.29-owl5
>         db4 = 4.3.29-owl5 is needed by (installed) db4-utils-4.3.29-owl5
> 
> If I replace -U with -i, it still complains about /etc/mime.types, which
> I've got no idea where's packed (certainly it doesn't help just to place
> mime.types in /etc, it needs to come from a package), and if I try -ivh
> --nodeps, it refuses to downgrade db4.

To find out where /etc/mime.types comes from on CentOS, download their
rpmdb-CentOS package (such as rpmdb-CentOS-4.8-0.20090804.i386.rpm),
install it, then issue:

bash-3.1# rpm --dbpath /usr/lib/rpmdb/i386-redhat-linux/CentOS -qf /etc/mime.types
mailcap-2.1.17-1

I just did the above on a chroot'ed test install of Owl-current, and it
worked just fine as you can see.  Yes, you have to know about their
rpmdb package, but other package names you can infer using that one.
Feel free to add info on the rpmdb package to our wiki page if you feel
that it is of sufficient relevance.

Speaking of db4, you can install the older version from CentOS on
Owl-current along with our newer version by running:

rpm -ivh --force db4-4.2.52-7.3.el4.i386.rpm

I've just tested this, it works fine.  Without "--force", it would say:

        package db4-4.3.29-owl4 (which is newer than db4-4.2.52-7.3.el4) is already installed

Once you install mailcap and db4, you may be able to install httpd and
the rest of the packages needed for it.  (I did not test that.)

If you install on Owl 2.0-stable, then you won't need to install db4
from CentOS, because our version in 2.0-stable matches that of RHEL4.

> So, the recommendation about CentOS packages should perhaps be reconsidedred.

CentOS 4 packages are typically usable on Owl - even in this tricky case
as you can see, but with proper install commands.  The wiki page at
http://openwall.info/wiki/Owl/packages currently says:

"In almost all cases, it is possible to install packages from (or
intended for) RHEL4, CentOS 4, FC3 (and usually also FC4) on Owl 2.0 and
2.0-stable (and usually also on Owl-current)."

So it claims "almost all cases" as it relates to "Owl 2.0 and
2.0-stable", but only "usually" as it relates to "Owl-current".  I think
this is correct.  We may make adjustments in 2.1-stable after we start
that branch but prior to making a release on it in order to improve
RHEL4 compatibility of Owl 2.1 again.

Thank you for your testing, which happened to remind us of the db4
version issue.

Alexander

-- 
To unsubscribe, e-mail owl-users-unsubscribe@...ts.openwall.com and reply
to the automated confirmation request that will be sent to you.

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.