Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 28 Feb 2024 10:44:04 +0000
From: Daniel Gaspar <>
Subject: CVE-2024-26016: Apache Superset: Improper authorization validation
 on dashboards and charts import 

Affected versions:

- Apache Superset before 3.0.4
- Apache Superset 3.1.0 before 3.1.1


A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges.

This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.


Daniel Vaz Gaspar (remediation developer)
Matt Freyre (finder)


Powered by blists - more mailing lists

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.