Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 28 Feb 2024 10:33:39 +0000
From: Daniel Gaspar <>
Subject: CVE-2024-24779: Apache Superset: Improper data authorization when
 creating a new dataset 

Affected versions:

- Apache Superset before 3.0.4
- Apache Superset 3.1.0 before 3.1.1


Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.


Daniel Pedro Vaz Gaspar (remediation developer)
@DLT1412 (finder)


Powered by blists - more mailing lists

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.