Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Thu, 7 Mar 2019 21:25:21 +0100
From: Borislav Petkov <>
To: Andy Lutomirski <>
Cc: "H. Peter Anvin" <>, Nadav Amit <>,
	Rick Edgecombe <>,
	Ingo Molnar <>, LKML <>,
	X86 ML <>, Thomas Gleixner <>,
	Dave Hansen <>,
	Peter Zijlstra <>,
	Damian Tometzki <>,
	linux-integrity <>,
	LSM List <>,
	Andrew Morton <>,
	Kernel Hardening <>,
	Linux-MM <>, Will Deacon <>,
	Ard Biesheuvel <>,
	Kristen Carlson Accardi <>,
	"Dock, Deneen T" <>,
	Kees Cook <>,
	Dave Hansen <>,
	Masami Hiramatsu <>
Subject: Re: [PATCH v2 10/20] x86: avoid W^X being broken during modules

On Thu, Mar 07, 2019 at 12:02:13PM -0800, Andy Lutomirski wrote:
> Should we maybe rename these functions?  static_cpu_has() is at least
> reasonably obvious.  But cpu_feature_enabled() is different for
> reasons I've never understood, and boot_cpu_has() is IMO terribly
> named.  It's not about the boot cpu -- it's about doing the same thing
> but with less bloat and less performance.

Well, it does test bits in boot_cpu_data. I don't care about "boot" in
the name though so feel free to suggest something better.

> (And can we maybe collapse cpu_feature_enabled() and static_cpu_has()
> into the same function?)

I'm not sure it would be always ok to involve the DISABLED_MASK*
buildtime stuff in the checks. It probably is but it would need careful
auditing to be sure, first.


Good mailing practices for 400: avoid top-posting and trim the reply.

Powered by blists - more mailing lists

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.