Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Tue,  5 Jun 2018 00:10:57 +1000 (AEST)
From: Michael Ellerman <>
To: Michael Ellerman <>,
Subject: Re: [1/2] powerpc: Rename thread_struct.fs to addr_limit

On Mon, 2018-05-14 at 13:03:15 UTC, Michael Ellerman wrote:
> It's called 'fs' for historical reasons, it's named after the x86 'FS'
> register. But we don't have to use that name for the member of
> thread_struct, and in fact arch/x86 doesn't even call it 'fs' anymore.
> So rename it to 'addr_limit', which better reflects what it's used
> for, and is also the name used on other arches.
> Signed-off-by: Michael Ellerman <>

Series applied to powerpc next.


Powered by blists - more mailing lists

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.