Date: Thu, 19 Jan 2017 14:08:12 -0800 From: Kees Cook <keescook@...omium.org> To: Laura Abbott <labbott@...hat.com> Cc: Jason Wessel <jason.wessel@...driver.com>, Jonathan Corbet <corbet@....net>, Russell King <linux@...linux.org.uk>, Catalin Marinas <catalin.marinas@....com>, Will Deacon <will.deacon@....com>, "James E.J. Bottomley" <jejb@...isc-linux.org>, Helge Deller <deller@....de>, Martin Schwidefsky <schwidefsky@...ibm.com>, Heiko Carstens <heiko.carstens@...ibm.com>, Thomas Gleixner <tglx@...utronix.de>, Ingo Molnar <mingo@...hat.com>, "H. Peter Anvin" <hpa@...or.com>, "x86@...nel.org" <x86@...nel.org>, Rob Herring <robh@...nel.org>, "Rafael J. Wysocki" <rjw@...ysocki.net>, Len Brown <len.brown@...el.com>, Pavel Machek <pavel@....cz>, Mark Rutland <mark.rutland@....com>, Jessica Yu <jeyu@...hat.com>, "linux-doc@...r.kernel.org" <linux-doc@...r.kernel.org>, LKML <linux-kernel@...r.kernel.org>, "linux-arm-kernel@...ts.infradead.org" <linux-arm-kernel@...ts.infradead.org>, linux-parisc <linux-parisc@...r.kernel.org>, "linux-s390@...r.kernel.org" <linux-s390@...r.kernel.org>, Linux PM list <linux-pm@...r.kernel.org>, "kernel-hardening@...ts.openwall.com" <kernel-hardening@...ts.openwall.com> Subject: Re: [RFC][PATCH 0/2] Better hardening names On Wed, Jan 18, 2017 at 5:29 PM, Laura Abbott <labbott@...hat.com> wrote: > Hi, > > It's come up previously that CONFIG_DEBUG_SET_MODULE_RONX and > CONFIG_DEBUG_RODATA are not accurate names, mostly they should not have the > word 'debug' in them. This series attempts to change the names to something > a bit more descriptive and indicative of what they are actually used for these > days. > > I marked this RFC for > - Bike shedding purposes. > - A discussion of what defaults should be. The way I did the refactoring, both > options are default y. I'd appreciate comments if there is a better approach. > - Approach to split this up into more sub patches to make review/merging easier? > Or maybe it's fine. > > Quickly tested on arm/arm64/x86. > > Thanks, > Laura > > Laura Abbott (2): > security: Change name of CONFIG_DEBUG_RODATA > security: Change name of CONFIG_DEBUG_SET_MODULE_RONX Some day I'll quit reading my email backwards. :) I see you've got MODULE_RONX renamed too here, please ignore my comment about needing it "too". :) -Kees -- Kees Cook Nexus Security
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.