Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Fri, 15 Apr 2016 12:26:08 -0700
From: Kees Cook <>
To: Ingo Molnar <>
Cc: Yinghai Lu <>, Junjie Mao <>, 
	Josh Triplett <>, Andrew Morton <>, 
	Baoquan He <>, Ard Biesheuvel <>, 
	Matt Redfearn <>, "" <>, 
	"H. Peter Anvin" <>, Ingo Molnar <>, Borislav Petkov <>, 
	Vivek Goyal <>, Andy Lutomirski <>,, 
	Dave Young <>, 
	"" <>, LKML <>
Subject: Re: [PATCH v5 07/21] x86, boot: Fix run_size calculation

On Fri, Apr 15, 2016 at 1:31 AM, Ingo Molnar <> wrote:
> * Kees Cook <> wrote:
>> From: Yinghai Lu <>
>> Currently, the kernel run_size (size of code plus brk and bss) is
>> calculated via the shell script arch/x86/tools/
>> It gets the file offset and mem size of for the .bss and .brk sections in
>> vmlinux, and adds them as follows:
> 'of for'?
>> So, from this we can see that the existing run_size calculation is
>> 0x400000 too high.
> Btw., why is it too high? Were some sections discarded?

I'm not sure why it's that specific value, but the old method used the
section's ELF _file_ position, not the virtual address, and that
seemed to cause the problem.

>> [...] And, as it turns out, the correct run_size is
>> actually equal to VO_end - VO_text, which is certainly easier to calculate.
>> _end: 0xffffffff8205f000
>> _text:0xffffffff81000000
>> 0xffffffff8205f000 - 0xffffffff81000000 = 0x105f000
>> As a result, run_size is a simple constant, so we don't need to pass it
>> around; we already have voffset.h such things.
> (Typo.)
>> [...] We can share voffset.h
>> between misc.c and header.S instead of getting run_size in other ways.
>> This patch moves voffset.h creation code to boot/compressed/Makefile,
>> and switches misc.c to use the VO_end - VO_text calculation.
> Btw., 'run_size' is a pretty meaningless name, it doesn't really tell us the most
> important thing: that this is the complete size of the uncompressed kernel, the
> total physically continuous size we need to allocate to it so it can execute?
> So can we rename it to something more expressive, such as kernel_total_size or so?

You got it. Thanks again for digging through all this!


Kees Cook
Chrome OS & Brillo Security

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.