Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Fri, 25 Feb 2011 17:27:00 +0100
From: magnum <rawsmooth@...dband.net>
To: john-users@...ts.openwall.com
Subject: Re: Absolute latest version and patches?

On 02/22/2011 07:41 AM, Solar Designer wrote:
> If you like, you could submit a patch merging hmailserver support into
> jumbo in a way that lets this be enabled from the Makefile (and keep it
> disabled by default not to require newer OpenSSL than jumbo requires
> currently).  Then I'll include that patch (if it's done cleanly) in the
> next jumbo update.  This (and not git) will deal with having to merge
> changes between these two patches going forward.

I just found out the wonderful -D argument to diff, so I gave this a go 
as an excersise. It made half the work for me :-)

So here is such a patch. It's produced after Jumbo-12 (and the 
early-release and intrinsics stuff, but it does apply with one fuzz over 
a plain Jumbo-12) and I didn't bump the "02" since the name was changed 
anyway.

Sorry about the timestamps, I use git.

cheers
magnum

View attachment "john-1.7.6-jumbo-12-hmailserver-02.diff" of type "text/x-patch" (9355 bytes)

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.