Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Sat, 8 Jan 2011 01:35:23 +0300
From: Solar Designer <solar@...nwall.com>
To: john-users@...ts.openwall.com
Subject: Re: Problems compiling JtR with SAP patch

On Fri, Jan 07, 2011 at 03:45:28PM -0600, Jose Espin wrote:
> $ make clean linux-x86-mmx

Why not -sse2?  I doubt that your computer is 10+ years old.

> /usr/bin/ld: cannot find -lcrypto

"definitely crashing" provided the correct advice: you need to install
the OpenSSL "development" sub-package to build this.

> Is there a built version that
> contains the sap password patch and I can easily download and run?

Yes: the patch has since been merged into the jumbo patch, and there are
builds of JtR with the jumbo patch here:

http://download.openwall.net/pub/projects/john/contrib/linux/
http://openwall.info/wiki/john/custom-builds#Compiled-for-Linux-x86

(as well as other builds in the appropriate locations for systems other
than Linux).

> Does the pro version contain this?

No.

Alexander

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.