Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Fri, 7 Jan 2011 15:45:28 -0600
From: Jose Espin <joseespin1@...il.com>
To: john-users@...ts.openwall.com
Subject: Problems compiling JtR with SAP patch

I have been trying to compile the source after applying the patch for sap
passwords. After the patch is applied, I try to compile the src, but I get
an error.  I am using ubuntu and following these instructions:

$ tar xfz john-1.7.2.tar.gz
$ cd john-1.7.2/
$ patch -p1 <../john-1.7.2-SAPLover-1.diff
$ cd src
$ make clean linux-x86-mmx
but, get compilation errors and the executable is not created in the run
directory. Here are some of the errors I get:

sapB_fnt.c:234: warning: array subscript is above array bounds

After a few additional lines I get:

/usr/bin/ld: cannot find -lcrypto
collect2: ld returned 1 exit status
make[1]: *** [../run/john] Error1
make: *** [linux-x86-mmx] Error 2

I also tried building john-1.7.3.1, it seems to work fine until I apply the
patch 1.7.3.1-all-1 and get the following error when executing make:

oracle_fmt.c:7 fatal error: openssl/des.h no such file or directory
compilation terminated.
then a few more lines related to the error

I tried applying 1.7.3.2-all-2 without applying all-1 (since all-2 has the
sap password cracker), but then get a similar error stating that fatal error
and that another file or directory couldn't be found.

Thanks in advance for any assistance.  Is there a built version that
contains the sap password patch and I can easily download and run? Does the
pro version contain this?

Thanks again,

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.