Date: Mon, 9 Jul 2012 10:50:35 -0500 From: "jfoug" <jfoug@....net> To: <john-dev@...ts.openwall.com> Subject: magnum-jumbo and magnum-bleeding (NOT J7), and the source() function What direction should the fmt.methods.source() (currently named get_source) function take? I would propose this. 1. Rename it to source() (how Solar wants it). Also change any documentation, and -list= data to reference source 2. Move it to right after salt, this would be a more 'fitting' location. Currently in bleeding, it is at the bottom of the structure, but I simply put it there to get NULL pointers during early implementation, so I would not have to modify every _fmt.c file. 3. Get jumbo-bleed updated with these changes. 4. Move these changes into magnum-jumbo (since we have a Jumbo-7RC branch of git). Once this is done, bleeding and jumbo should be back to being much more 'similar' to each other. Some of these ideas need to be based upon the layout Solar will be doing with core JtR. I would certainly like to have this done in exactly the same way that this would be expected to be in core, so that we do not have to re-write once the core code provides this support function. Jim. Content of type "text/html" skipped
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.