Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Thu, 10 Nov 2011 16:24:12 +0400
From: Solar Designer <solar@...nwall.com>
To: owl-users@...ts.openwall.com
Subject: Re: Failed to build packages from pkgsrc

On Thu, Nov 10, 2011 at 12:28:05PM +0200, Henri Salo wrote:
> We also noticed major problems with irssi. I have sometimes seen these irssi-problems also in other platforms, but usually they go away automatically after refresh of the window. Screenshot tells it all: http://imageshack.us/photo/my-images/214/lolbep.png/
> 
> - Spaces between words without even writing those by ourselves
> - Blue panel goes dark and then we see duplicate lines in irssi
> 
> After this experience I think that nobody uses irssi in Owl or Owl in overall shell working environment. Terminal, irssi and shell settings are the same (UTF-8) as in Debian-environment where everything seems to work now as supposed.

Owl lacks utf-8 locales by default.  Yes, I know it sounds weird these
days, and we got to change it in Owl-current before Owl 4.0.

To enable them, change BUILD_LOCALES_UTF8 from 0 to 1 in glibc.spec and
rebuild glibc with "make PACKAGE=glibc".

Or simply change your settings to use iso-8859-1.

Alexander

Powered by blists - more mailing lists

Your e-mail address:

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.