Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 28 Feb 2024 10:12:53 +0000
From: Daniel Gaspar <>
Subject: CVE-2024-24773: Apache Superset: Improper validation of SQL
 statements allows for unauthorized access to data  

Affected versions:

- Apache Superset before 3.0.4
- Apache Superset 3.1.0 before 3.1.1


Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.


Beto Ferreira De Almeida (remediation developer)
Daniel Vaz Gaspar (coordinator)


Powered by blists - more mailing lists

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.