Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [day] [month] [year] [list]
Date: Tue, 13 Jul 2021 04:01:23 +0000
From: Stefan Bodewig <>
Subject: CVE-2021-35517: Apache Commons Compress 1.1 to 1.20 denial of
 service vulnerability 


When reading a specially crafted TAR archive, Compress can be made to allocate large amounts of memory that finally leads to an out of memory error even for very small inputs. This could be used to mount a denial of service attack against services that use Compress' tar package.


Commons Compress users should upgrade to 1.21 or later.


This issue was discovered by OSS Fuzz.


Powered by blists - more mailing lists

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.