Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 9 Oct 2019 16:57:52 +0200
From: Patrick Uiterwijk <puiterwijk@...hat.com>
To: oss-security@...ts.openwall.com
Subject: Koji CVE-2019-17109: koji hub allows arbitrary upload destinations

Description
===========

The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. 


Affected versions
=================

All prior versions of Koji are vulnerable.


Patched versions
================

Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 are available on the website, and all include patches to solve this problem.


Credits
=======

This issue was discovered by Yu Ming Zhu of Red Hat.


References
=========

https://docs.pagure.org/koji/CVE-2019-17109/

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.