Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Tue, 8 Oct 2019 18:11:31 +0200
From: Pietro Albini <pietro@...troalbini.org>
To: oss-security@...ts.openwall.com
Subject: CVE-2019-16760: Cargo prior to Rust 1.26.0 may download the wrong
 dependency

On 2019-09-30 the Rust Security team disclosed a vulnerability affecting 
all Rust releases prior to 1.26.0, causing Cargo to download and compile 
the wrong dependency under the right circumstances.

The vulnerability has been assigned CVE-2019-16760.

As the affected versions are not supported anymore upstream we won't be 
issuing patch releases addressing this vulnerability. Official patches 
(signed with the security team's GPG key) for Rust 1.19.0 to Rust 1.25.0 
are available here:

https://gist.github.com/pietroalbini/0d293b24a44babbeb6187e06eebd4992

More information on the vulnerability can be found in the advisory:

https://groups.google.com/forum/#!topic/rustlang-security-announcements/rVQ5e3TDnpQ

Pietro.
Rust Security team

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.