Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Sat, 6 Oct 2018 13:40:04 +0200
From: joernchen <joernchen@...noelit.de>
To: oss-security@...ts.openwall.com
Subject: CVE-2018-17456 Git RCE via .gitmodules

Hey,

just a short heads up to oss-sec:

Git has just [0] released Versions 2.14.5, 2.15.3, 2.16.5, 2.17.2,
2.18.1, and 2.19.1 which mitigate CVE-2018-17456, an RCE issue I found
within the handling of Git submodules.

More specifically this issue allows execution of arbitrary commands via
a argument injection to subsequent `git clone` operations using the
`url` parameter in the `.gitmodules` file. 


Cheers,

joernchen

[0] https://marc.info/?l=git&m=153875888916397&w=2

--
joernchen ~ Phenoelit
<joernchen@...noelit.de> ~ C776 3F67 7B95 03BF 5344
http://www.phenoelit.de  ~ A46A 7199 8B7B 756A F5AC

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.