Date: Wed, 11 Jul 2018 15:18:36 -0500 From: Sean Owen <srowen@...che.org> To: "oss-security@...ts.openwall.com" <oss-security@...ts.openwall.com> Subject: CVE-2018-1334 Apache Spark local privilege escalation vulnerability Severity: High Vendor: The Apache Software Foundation Versions affected: Spark versions through 2.1.2 Spark 2.2.0 to 2.2.1 Spark 2.3.0 Description: In Apache Spark up to and including 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application. Mitigation: 1.x, 2.0.x, and 2.1.x users should upgrade to 2.1.3 or newer 2.2.x users should upgrade to 2.2.2 or newer 2.3.x users should upgrade to 2.3.1 or newer Otherwise, affected users should avoid using PySpark and SparkR in multi-user environments. Credit: Nehmé Tohmé, Cloudera, Inc. References: https://spark.apache.org/security.html
Powered by blists - more mailing lists
Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.