Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Tue, 12 Jun 2018 14:11:34 -0700
From: Anthony Baker <abaker@...otal.io>
To: user@...de.apache.org, dev@...de.apache.org, announce@...che.org,
        asf-security <security@...che.org>, oss-security@...ts.openwall.com
Subject: [SECURITY] CVE-2017-15695 Apache Geode remote code execution vulnerability

CVE-2017-15695 Apache Geode remote code execution vulnerability

Severity:  Important

Vendor: The Apache Software Foundation

Versions Affected:  Apache Geode 1.0.0 through 1.4.0

Description:
When a Geode server is configured with a security manager, a user with
DATA:WRITE privileges is allowed to deploy code by invoking an
internal Geode function.  This allows remote code execution.  Code
deployment should be restricted to users with DATA:MANAGE privilege.

Mitigation:
Users of the affected versions should upgrade to Apache Geode 1.5.0 or later.

Credit:
This issue was reported responsibly to the Apache Geode Security Team
by Dan Smith from Pivotal Software.

References:
[1] https://issues.apache.org/jira/browse/GEODE-3974
[2] https://cwiki.apache.org/confluence/display/GEODE/Release+Notes#ReleaseNotes-SecurityVulnerabilities

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.