Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 5 Jun 2018 17:11:11 +0000
From: "Rai, Harendra" <>
To: Denis Magda <>,
        dev <>,
Subject: RE: [CVE-2014-0114]: Apache Ignite is vulnerable to existing

I found other security issues and I have created a bug.

Harendra Rai
Software Engineer
NCR Corporation
office: 770.495.2864
mobile: 248.787.2876<><>

From: Denis Magda []
Sent: Friday, June 01, 2018 1:17 PM
To:; dev <>;;; Rai, Harendra <>
Subject: [CVE-2014-0114]: Apache Ignite is vulnerable to existing CVE-2014-0114

[CVE-2014-0114]: Apache Ignite is vulnerable to existing CVE-2014-0114

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected: Apache Ignite 2.4 or earlier

An attacker can execute arbitrary code on Ignite nodes in the case when Ignite classpath contains arbitrary vulnerable classes.

Apache Ignite used commons-beanutils-1.8.3.jar library which did not suppress the class property, which allowed remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.

•    All Ignite versions: make sure there are no vulnerable classes among your custom code used in Apache Ignite.
•    Upgrade to Apache Ignite 2.5 or later version

Harendra Rai of NCR Corporation discovered the impact of the existing vulnerability on Apache Ignite.


Content of type "text/html" skipped

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.