Date: Sat, 28 Mar 2015 13:06:50 +0100 From: magnum <john.magnum@...hmail.com> To: john-dev@...ts.openwall.com Subject: get_binary() vs. binary() It has been mentioned a couple times over the years that our mix of salt() vs. get_salt() and binary() vs. get_binary() was confusing. Today I tried refactoring all non-core formats to use salt() and binary() but that ended up really messy (eg. often clashing with variable names) so I reverted it. After noticing that "john proper" actually mostly does use the get_* names within the formats, I decided to adopt that in Jumbo instead: Now most formats use get_salt() and get_binary() while core code and format struct have them as just salt() and binary(). This was a much cleaner patch and I think it ends up with code easier to read. I left all core formats as-is in the few cases they diverted from this scheme. We have far to many unnecessary changes to core code and all such changes are subject to be reverted at any time I merge core. Jumbo should basically add to core, not change it. magnum
Powered by blists - more mailing lists
Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.