Follow @Openwall on Twitter for new release announcements and other news
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 10 Jul 2012 14:51:57 +0400
From: Solar Designer <>
Subject: Re: magnum-jumbo and magnum-bleeding (NOT J7), and the source() function

On Mon, Jul 09, 2012 at 10:50:35AM -0500, jfoug wrote:
> What direction should the fmt.methods.source() (currently named get_source)
> function take?
> I would propose this.
> 1.       Rename it to source()  (how Solar wants it).  Also change any
> documentation, and -list= data to reference source

Yes.  However, since the official source() interface, when it appears,
might be subtly different from what we're experimenting with now, the
rename might as well be postponed.

> 2.       Move it to right after salt, this would be a more 'fitting'
> location.

Agreed.  That's where I was going to put it.

> 3.       Get jumbo-bleed updated with these changes.

Maybe, or not yet.  That's up to you.

> 4.       Move these changes into magnum-jumbo  (since we have a Jumbo-7RC
> branch of git).   Once this is done, bleeding and jumbo should be back to
> being much more 'similar' to each other.

OK, but note that the official source() interface might be different.

> Some of these ideas need to be based upon the layout Solar will be doing
> with core JtR.  I would certainly like to have this done in exactly the same
> way that this would be expected to be in core, so that we do not have to
> re-write once the core code provides this support function.

Well, I do not yet know all details about how I'll implement this in
core.  I only have my current thoughts on the matter.  I'll reply to
your other message with some of that now.


Powered by blists - more mailing lists

Confused about mailing lists and their use? Read about mailing lists on Wikipedia and check out these guidelines on proper formatting of your messages.