Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 15 Nov 2017 08:38:25 +0000 (UTC)
From: Andrea Cosentino <ancosen1985@...oo.com>
To: Dev <dev@...el.apache.org>, Users <users@...el.apache.org>, 
	Security <security@...che.org>, 
	"oss-security@...ts.openwall.com" <oss-security@...ts.openwall.com>, 
	Moritz Bechler <bechler@...o3.eu>
Subject: [SECURITY] New security advisory CVE-2017-12633 released for Apache
 Camel

A new security advisory has been released for Apache Camel, that is fixed in
the recent 2.19.4 and 2.20.1 releases:

CVE-2017-12633: Apache Camel's Hessian unmarshalling operation is vulnerable to Remote Code Execution attacks

The full text of the advisory is the following:

CVE-2017-12633: Apache Camel's Hessian unmarshalling operation is vulnerable to Remote Code Execution attacks

Severity: MEDIUM

Vendor: The Apache Software Foundation

Versions Affected: Camel 2.19.0 to 2.19.3 and Camel 2.20.0
The unsupported Camel 2.x (2.18 and earlier) versions may be also affected.

Description: Apache Camel's camel-hessian component is vulnerable to Java object
de-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.

Mitigation: 2.19.x users should upgrade to 2.19.4, 2.20.0 users should upgrade to 2.20.1. 

The JIRA ticket: https://issues.apache.org/jira/browse/CAMEL-11923
refers to the various commits that resovoled the issue, and have more details.

Credit: This issue was discovered by Moritz Bechler from AgNO3 GmbH & Co.

On behalf of the Apache Camel PMC

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Member
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@...oo.com
Twitter: @oscerd2
Github: oscerd

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ