Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 15 Nov 2017 08:34:51 +0000 (UTC)
From: Andrea Cosentino <>
To: Dev <>, Users <>, 
	Man Yue Mo <>, 
	"" <>, 
	"" <>
Subject: [SECURITY] New security advisory CVE-2017-12634 released for Apache

A new security advisory has been released for Apache Camel, that is fixed in
the recent 2.19.4 and 2.20.1 releases:

 CVE-2017-12634: Apache Camel's Castor unmarshalling operation is vulnerableto Remote Code Execution attacks

The full text of the advisory is the following:

CVE-2017-12634: Apache Camel's Castor unmarshalling operation is vulnerable to Remote Code Execution attacks 

Severity: MEDIUM

Vendor: The Apache Software Foundation

Versions Affected: Camel 2.19.0 to 2.19.3 and Camel 2.20.0. The unsupported Camel 2.x (2.18 and earlier) versions may be also affected.

Description: Apache Camel's camel-castor component is vulnerable to Java objectde-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.

Mitigation: 2.19.x users should upgrade to 2.19.4, 2.20.0 users should upgrade to 2.20.1. 

The JIRA ticket: refers to the various commits that resovoled the issue, and have more details.

Credit: This issue was discovered by Man Yue Mo <mmo at semmle dot com> from Semmle/ behalf of the Apache Camel PMC

On behalf of the Apache Camel PMC

Andrea Cosentino 
Apache Camel PMC Member
Apache Karaf Committer
Apache Servicemix PMC Member
Twitter: @oscerd2
Github: oscerd

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ