Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Sat, 23 Jan 2016 16:27:41 +0300
From: gremlin@...mlin.ru
To: owl-users@...ts.openwall.com
Subject: Re: Owl VZ templates cannot rebuild themselves?

On 2016-01-22 17:25:27 -1000, cpb wrote:

 > Hi everyone, I am probably doing something wrong, but I was trying
 > to rebuild the Owl-current (20150801) templates from themselves,
 > and I had a problem: the owl-startup RPM couldn't be built because
 > it has a build dependency on libpopt-devel-static, which is not
 > installed inside the template.

[here were several kilobytes of obscene words, skipped for brevity]

 > libpopt-devel-static is not mentioned in installorder.conf

Obviously, it should be. Next after libpopt-devel package.
Most likely, that was missed when splitting the -static subpackage.

 > so...it doesn't get installed that way. I don't know how it got
 > installed in the ISOs! Maybe an rpm -Ivh *

On `rpm -I`: almost all people should use `rpm -U` instead, unless
they really (1) know what they do and (2) need that.

 > was run instead of make installworld?

ISOs and VZ templates are built using different rules.

 > It's easy to cure, but (1) I don't know if there's really a
 > problem and (2) I don't know what way is the "best" cure.

The best way is to add libpopt-devel-static to installorder.conf
We'll do that as well.


-- 
Alexey V. Vissarionov aka Gremlin from Kremlin
GPG: 8832FE9FA791F7968AC96E4E909DAC45EF3B1FA8

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ