Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Thu, 23 Aug 2012 01:51:37 +0400
From: "Dmitry V. Levin" <ldv@...linux.org>
To: owl-dev@...ts.openwall.com
Subject: Re: __libc_enable_secure with new binutils

On Tue, Aug 14, 2012 at 07:44:34AM +0400, Solar Designer wrote:
> On Tue, Aug 14, 2012 at 07:00:12AM +0400, Solar Designer wrote:
> > Dmitry - did you run into this issue in ALT Linux?
> 
> Oh, here it is:
> 
> http://git.altlinux.org/people/ldv/packages/?p=glibc.git;a=commitdiff;h=b6d96f871268df4944204f139f3d4435f0243303
> 
> (move __libc_enable_secure out of GLIBC_PRIVATE in elf/Versions).
> 
> I'll get this into Owl now.

The reason I placed __libc_enable_secure into GLIBC_2.0 section is that
it was there until commit glibc-2.2.4-506-gfb23eb2 moved it to
GLIBC_PRIVATE.

> I wonder why we did not run into this issue in Owl earlier.  This patch
> in ALT Linux dates back to 2009, whereas our previous binutils update
> was in 2010.

Yes, this is very surprising.  Maybe build scripts filter out
GLIBC_PRIVATE requirements somehow.  The patch is actually older,
it was rebased in 2008.


-- 
ldv

[ CONTENT OF TYPE application/pgp-signature SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ