Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 22 Oct 2011 14:12:13 +0400
From: "Dmitry V. Levin" <ldv@...linux.org>
To: owl-dev@...ts.openwall.com
Subject: Re: support for newer Fedora

Hi,

On Sat, Oct 22, 2011 at 08:21:56AM +0400, Solar Designer wrote:
> 
> Fedora 13 runs in OpenVZ container on Owl 3.0 and -current just fine.
> (In fact, I run Xilinx ISE in this way - a 20 GB software install.)
> 
> Fedora 14 is the latest of Fedoras that I am able to run on Owl-current,
> after faking the kernel version number with
> "sysctl -w kernel.virt_osrelease=2.6.32".  (The kernel actually has the
> necessary backports.)  Maybe vzctl should do this for Fedora 14+ on its
> own?  Maybe newer vzctl already does it?
> 
> Fedora 15 gets stuck in what appears in ps as "init -z".  strace shows
> that it's doing pause().  I guess systemd is incompatible with our
> kernel and/or vzctl.  Is this something we can fix without major
> updates?  I'd like a fix suitable for 3.0-stable if possible.  (Indeed,
> we'll eventually update to RHEL 6 kernels and latest vzctl in
> Owl-current, which will obviously make Fedora 15+ work.)

I have no personal experience with running Fedora 14+ ovz containers, but,
according to vzctl changelog, some changes were made to address these and
other Fedora 14+ and 15+ issues.  In other words, vzctl package needs to
be updated.


-- 
ldv

[ CONTENT OF TYPE application/pgp-signature SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ