Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Tue, 12 Apr 2011 10:52:41 +0100
From: Simon Baker <simonb@...zo.org>
To: owl-dev@...ts.openwall.com
Subject: OpenSSL Upgrade: installworld errors


Hi All,

Is there a recommended way to upgrade from Owl 3.0-stable 2011/03/12 to 
-current?  I'm hitting dependency issues with the old vs. new SSL libraries:

10:40:03: Installing openssl openssl-devel openssl-perl mtree openssh 
openssh-clients openssh-server openssh-blacklist elinks nmap ncat nping 
mutt openntpd readline readline-devel bc gnupg gdb lftp 
(openssl-1.0.0d-owl1.x86_64.rpm openssl-devel-1.0.0d-owl1.x86_64.rpm 
openssl-perl-1.0.0d-owl1.x86_64.rpm mtree-3.7.20050808-owl2.x86_64.rpm 
openssh-3.6.1p2-owl27.x86_64.rpm 
openssh-clients-3.6.1p2-owl27.x86_64.rpm 
openssh-server-3.6.1p2-owl27.x86_64.rpm 
openssh-blacklist-3.6.1p2-owl27.x86_64.rpm elinks-0.11.7-owl1.x86_64.rpm 
mutt-1.4.2.3-owl1.x86_64.rpm openntpd-3.7p1-owl5.x86_64.rpm 
readline-5.1-owl1.x86_64.rpm readline-devel-5.1-owl1.x86_64.rpm 
bc-1.06-owl8.x86_64.rpm gnupg-1.4.11-owl1.x86_64.rpm 
gdb-6.3-owl4.x86_64.rpm lftp-4.1.1-owl1.x86_64.rpm)
error: Failed dependencies:
     libcrypto.so.5()(64bit) is needed by mtree-3.7.20050808-owl2
     libcrypto.so.5()(64bit) is needed by openssh-3.6.1p2-owl27
     libcrypto.so.5()(64bit) is needed by openssh-clients-3.6.1p2-owl27
     libcrypto.so.5()(64bit) is needed by openssh-server-3.6.1p2-owl27
     libcrypto.so.5()(64bit) is needed by elinks-0.11.7-owl1
     libssl.so.5()(64bit) is needed by elinks-0.11.7-owl1
     libcrypto.so.5()(64bit) is needed by mutt-1.4.2.3-owl1
     libssl.so.5()(64bit) is needed by mutt-1.4.2.3-owl1
     libcrypto.so.5()(64bit) is needed by openntpd-3.7p1-owl5
     libcrypto.so.5()(64bit) is needed by lftp-4.1.1-owl1
     libssl.so.5()(64bit) is needed by lftp-4.1.1-owl1
     libcrypto.so.5()(64bit) is needed by (installed) ncat-5.21-owl2
     libcrypto.so.5()(64bit) is needed by (installed) nmap-5.21-owl2
     libcrypto.so.5()(64bit) is needed by (installed) lftp-.1.1-owl1
     libssl.so.5()(64bit) is needed by (installed) ncat-5.21-owl2
     libssl.so.5()(64bit) is needed by (installed) nmap-5.21-owl2
     libssl.so.5()(64bit) is needed by (installed) lftp-4.1.1-owl1
10:40:03: Failed openssl openssl-devel openssl-perl mtree openssh 
openssh-clients openssh-server openssh-blacklist elinks nmap ncat nping 
mutt openntpd readline readline-devel bc gnupg gdb lftp

Is there a recommended upgrade magic?  I can't see anything on 
http://openwall.info/wiki/Owl/upgrade , but if there's an 'official' way 
to upgrade rather than forcing it via rpm install I'll document it there.

Regards,

Simon.

[ CONTENT OF TYPE text/html SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ