Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 13 Apr 2011 22:31:00 +0400
From: Vasiliy Kulikov <segoon@...nwall.com>
To: owl-dev@...ts.openwall.com
Subject: Re: OpenSSL Upgrade: installworld errors

Hi Simon,

On Tue, Apr 12, 2011 at 10:52 +0100, Simon Baker wrote:
> Is there a recommended way to upgrade from Owl 3.0-stable 2011/03/12
> to -current?  I'm hitting dependency issues with the old vs. new SSL
> libraries:

Unfortunately, there is no simple way.  However, there is a choise:

1) remove everything depending on openssl*, install openssl, install
everything, but openssh, recompile openssh, install openssh.

2) install openssl-devel with "--nodeps", recompile and reinstall everything.

openssh is a special exception because of a runtime strict dependency
check of openssl version.


Thanks,

-- 
Vasiliy

[ CONTENT OF TYPE application/pgp-signature SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ