Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sun, 01 Jun 2014 00:13:36 +0200
From: "[Jano]" <jano@...oweb.net>
To: john-dev@...ts.openwall.com
Subject: Re: Warnings with new autoconf on bleeding-jumbo

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

magnum ha scritto:
> On 2014-05-31 21:10, [Jano] wrote:
>> I get these warnings when building the latest bleeding-jumbo using new
>> "./configure":
>> (./configure --enable-mpi && make -s clean && make -sj4)
>
>> DES_std.c: In function ‘DES_std_set_key’:
>> DES_std.c:637:17: warning: array subscript is above array bounds
>> [-Warray-bounds]
>>     while (DES_key[i++]) k += 2;
>
> This warning (seen even "non-Jumbo" JtR) is just a red herring from
> gcc. If you revert to gcc-4.7 you don't see it, while gcc-4.8 and
> 4.9 (if memory serves me) show it. Nothing to worry about. I
> actually use 4.7 most of the time just for this reason (I'm not
> aware of any performance benefits of the newer ones).
>
> magnum
>
>
I imagined that it was the problem, by default the latest Ubuntu
version uses  gcc-4.8 and I have problems also with other programs.

Ok, well I installed also the gcc/g++ 4.7.
Thanks, Dario
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iF4EAREIAAYFAlOKVA4ACgkQGMW0o6a6YTIdIwD/WhBCln6HLOpxZDCnQ3n6608t
s1Jk8YrVZZJHWkdhHfIA/3pUTSywqH9+THD7dub8mh0nHyPB+U+lvOMPyHe+XFlq
=qTdY
-----END PGP SIGNATURE-----

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ