Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Sun, 24 Mar 2013 14:15:27 +0530
From: Dhiru Kholia <dhiru.kholia@...il.com>
To: john-dev@...ts.openwall.com
Subject: new warnings with gcc 4.8.0

Hi,

I tried to build unstable-jumbo with gcc 4.8.0 and got some new
warnings.

Can we fix them before Jumbo8 release?

--
Dhiru

DES_std.c: In function ‘DES_std_set_key’:
DES_std.c:631:17: warning: array subscript is above array bounds [-Warray-bounds]
   while (DES_key[i++]) k += 2;
                 ^
dynamic_fmt.c: In function ‘init’:
dynamic_fmt.c:842:27: warning: iteration 8u invokes undefined behavior [-Waggressive-loop-optimizations]
    total_len2[i*MMX_COEF] = 32;
                           ^
dynamic_fmt.c:837:3: note: containing loop
   for (i = 0; i < BLOCK_LOOPS; ++i) {
   ^
rawSHA1_ng_fmt.c:559:3: warning: #warning not using optimized sse4.1 compare because -msse4 was not specified [-Wcpp]
 # warning not using optimized sse4.1 compare because -msse4 was not specified
   ^
inc.c: In function ‘do_incremental_crack’:
inc.c:352:12: warning: array subscript is above array bounds [-Warray-bounds]
    [numbers[pos]];
            ^
inc.c:352:12: warning: array subscript is above array bounds [-Warray-bounds]
inc.c:405:16: warning: array subscript is above array bounds [-Warray-bounds]
   if (++numbers[pos] <= count) goto update_all;
                ^
inc.c:405:16: warning: array subscript is above array bounds [-Warray-bounds]
inc.c:405:16: warning: array subscript is above array bounds [-Warray-bounds]
inc.c:405:16: warning: array subscript is above array bounds [-Warray-bounds]
inc.c:406:10: warning: array subscript is above array bounds [-Warray-bounds]
   numbers[pos] = 0;


Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ