Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 9 Nov 2011 07:25:56 -0600
From: "JimF" <jfoug@....net>
To: <john-dev@...ts.openwall.com>
Subject: Re: inadvertent OpenMP 3.0 dependencies

This was the only instance that I saw.  VC also uses 2.5 (I believe).  At least it complained about needing a signed int.

Jim.

From: "Solar Designer" <solar@...nwall.com>

> magnum -
> 
> I think it is desirable for our code to also build with compilers that
> support only OpenMP 2.5, but not OpenMP 3.0+.  One of these is gcc
> versions 4.2.x and 4.3.x.  (OpenMP 3.0 is available starting with gcc
> 4.4, as far as I understand.)  Another is EKOPath 4:
> 
> http://www.pathscale.com/ekopath4-open-source-announcement
> 
> 0024-j7-sapB-sapG-added-OMP-and-proper-hash-functions.patch
> inadvertently introduced a dependency on OpenMP 3.0 here:
> 
> +       unsigned int i;
> +
> +#ifdef _OPENMP
> +#pragma omp parallel for
> +#endif
> +       for (i = 0; i < count; i++) {
> 
> In OpenMP 2.5, the loop variable should be signed.

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ