Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 21 Sep 2011 08:01:42 +0200
From: magnum <rawsmooth@...dband.net>
To: john-dev@...ts.openwall.com
Subject: Re: No problem seen in Jumbo-6-RC5+0002 (was Problem seen
 in 1.7.8-Jumbo-6-RC3)

On 2011-09-21 02:25, JimF wrote:
>> As a sidenote, I can't cross-compile 64-32 targets unless removing the
>> -lz from LDFLAGS but when I do, everything builds and runs fine
>> including pkzip. It builds and runs fine with OR without -lz using
>> normal linux-x86-64. Is -lz needed on other systems?
>
> Could this be due to how the openssl was built on your system? I am
> pretty sure I had problem on both cygwin, and solaris, without the lz.

Probably. I have "multilib" versions (i.e. both 32-bit and 64-bit 
versions in separate dirs) of other libraries but there is just one 
libz. Some way it seems to have that 32/64 support made different than 
usual. Anyway I only have problems with the cross compiled test builds 
so this is not very important.

magnum

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ