Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Thu, 16 Jun 2011 15:24:36 -0400 (EDT)
From: rs904c@...scape.net
To: john-dev@...ts.openwall.com
Subject: Error with static linking in jumbo 6


John-Dev,
 
I recently attempted to build JtR with jumbo 6 on Linux x86 32-bit and 64-bit.   Since my goal is to upload to the wiki, so others can possibly use it, I statically link to OpenSSL and to glibc.   But this is causing two fatal errors. I’m getting errors with libcrypto.a.  I can’t past the code right now.
However, when I remove the static linking to OpenSSL and to glibc, the errors don’t occur and I get a successful build.
Is the solution to apply the patch john-1.7.7-jumbo-6-auto_have_sha256-03.diff.gz, or is some other error been introduced into jumbo 6?   I can’t apply the above patch right now to test.
-Robert B. Harris from VA



[ CONTENT OF TYPE text/html SKIPPED ]

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ