Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Mon, 13 Jun 2011 23:19:28 +0200
From: magnum <rawsmooth@...dband.net>
To: john-dev@...ts.openwall.com
Subject: Re: SybaseASE / hmailserver automagic enable

On 2011-06-12 04:10, Solar Designer wrote:
> On Thu, Jun 09, 2011 at 08:35:26PM +0200, magnum wrote:
>> I just uploaded a patch that removes the -DHAVE_OPENSSL_SHA256 stuff in
>> favor of an OpenSSL version macro, so SybaseASE and hmailserver are
>> automagically enabled if the OpenSSL version is new enough. Seems to
>> work like a champ.
> Thanks!
>
>> Is there any reason against doing this?
> No, I just overlooked the possibility.
>
> As to an #else with #warning, I think we need to wrap the #warning in
> #ifdef __GNUC__ ... #endif, or some non-GNU cpp might complain.

I threw this in (in revision 03 of the patch) as I was posting other 
stuff anyway

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ