Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Mon, 19 Jan 2009 11:55:03 -0600 (CST)
From: "Josh Larocque" <josh@...experts.ca>
To: popa3d-users@...ts.openwall.com
Cc: 
Subject: Authentication Failure

Hi,

I'm running Fedora Core 8 (upgraded using yum from FC5.)  The problem I'm having crept in through the upgrade process to FC8.  popa3d was running fine on FC5 until this upgrade.  The system has several mailboxes, all of which are now having authentication failures on login attempts with the following output:

+OK
user joshlarocque
+OK
pass xxxxxxxx
-ERR Authentication failed (bad password?)

With the following error in the logs:

Jan 19 11:44:03 phpexperts xinetd[23682]: START: pop3 pid=7679 from=::ffff:99.242.74.167
Jan 19 11:44:06 phpexperts popa3d[7679]: Authentication failed for joshlarocque from 99.242.74.167
Jan 19 11:44:06 phpexperts xinetd[23682]: EXIT: pop3 status=0 pid=7679 duration=3(sec)

I am, however, able to log into the system as this user and can access the mailbox with the 'mail' command.

The mail directory and mailbox have the following permissions:

drwxrwxr-x 2 root         mail      4096 Jan 19 11:45 /var/spool/mail
-rw------- 1 joshlarocque mail 656253515 Jan 19 11:47 /var/spool/mail/joshlarocque

After reading the existing threads on this list, I tried emptying the mail box using '> /var/spool/mail/joshlarocque', but I get the same error.

Any help would be greatly appreciated.  Is there some possible authentication disconnect between popa3d and the system?  What other packages could I focus on troubleshooting to resolve this issue?

Thanks,

Josh

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ