Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Tue, 14 Aug 2012 07:00:12 +0400
From: Solar Designer <solar@...nwall.com>
To: owl-dev@...ts.openwall.com
Subject: __libc_enable_secure with new binutils

Dmitry, Vasily -

After binutils upgrade to 2.23.51.0.1 (maybe also after Vasily's upgrade
to 2.22.52.0.1 - I just did not test it) and some Owl rebuilds
(including rebuild of other packages with glibc previously rebuilt with
the new binutils), packages that use __libc_enable_secure have started
to require ld-linux-x86-64.so.2(GLIBC_PRIVATE)(64bit) (and probably
something similar on other archs).  As a workaround, I am thinking of
having our glibc provide it (right from glibc.spec), but what would your
recommended fix be?  Perhaps make __libc_enable_secure more official?

Dmitry - did you run into this issue in ALT Linux?

Thanks,

Alexander

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux - Powered by OpenVZ