Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date: Thu, 12 Apr 2012 22:43:09 +0400
From: Solar Designer <solar@...nwall.com>
To: owl-dev@...ts.openwall.com
Subject: lftp update

Mesut -

Please update the lftp package in Owl-current to the latest release
(currently 4.3.6).  Also, we may want to patch this in Owl 3.0-stable:

$ lftp
lftp :~> torrent a
lftp: Torrent.cc:119: Torrent::Torrent(const char*, const char*, const char*): Assertion `my_peer_id.length()==PEER_ID_LEN' failed.
Aborted

This is only seen in the x86_64 build, but not in the i686 build.

I suggest that we start by updating lftp in Owl-current to latest, then
if there are no issues with it for a while just include this update into
3.0-stable as well.  This will likely eliminate the need for
investigating and patching the above issue separately (I guess it is
already fixed upstream).

Thanks,

Alexander

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ