Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Fri, 4 Nov 2011 15:06:38 +0400
From: Vasiliy Kulikov <segoon@...nwall.com>
To: owl-dev@...ts.openwall.com
Subject: Owl needs modern gdb for PIE (was: %optflags for new gcc)

On Fri, Nov 04, 2011 at 04:37 +0400, Solar Designer wrote:
> 5. PIE is another thing we may want to enable selectively (like "full
> RELRO") or to let our advanced users enable fully (in their rebuild of
> Owl)

Also, for PIE support in gdb we must upgrade gdb after glibc.  Old gdb
doesn't work with PIE.

https://lwn.net/Articles/379511/

-- 
Vasiliy

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ