Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Thu, 8 Sep 2011 14:46:34 +0200
From: Daniel Cegiełka <daniel.cegielka@...il.com>
To: owl-dev@...ts.openwall.com
Subject: Re: gcc 4.6.1

What version of glibc you plan to use? I have gentoo with owl patches
and many diffs I use with glibc-2.12. I have a problem with compiling
sanitize-env.diff (glibc-2.12 and gcc-4.6.1). And there is a problem
with perl-5.8.8 compilation with glibc-2.14 and gcc-4.6.1... perl-5.10
works ok.

regards,
daniel


2011/9/8 Solar Designer <solar@...nwall.com>:
> Vasiliy,
>
> On Thu, Sep 08, 2011 at 03:26:56PM +0400, Vasiliy Kulikov wrote:
>> I've reached approx. the point Georgi has stopped.  I have packaged the
>> basic gcc (c and c++) and the dependencies (mpfr, mpc, gpm).
>
> Oh, I thought you'd ask me for a copy of Georgi's stuff first.  But I
> think you haven't spent much time on this anyway.
>
>> I haven't
>> ported Fedora/ALT patches yet.  Now I'll try to fix build failures (the
>> same as Georgi posted) - they look like more strict use without (or
>> wrong) declaration rules and similar.  I'll try to patch the packages
>> without breaking gcc 3.4.5 compilation ability.  However, it seems glibc
>> has some major problems, will investigate further.
>
> OK.
>
>> Btw, there are numerous "var may be used uninitialized", "wrong format
>> string", "unused variable" and even "operation on var is undefined".
>> I'll fix them as far as I work on the specific package.
>
> Sounds fine, but please don't spend much time fixing these in packages
> that we intend to upgrade to newer versions before Owl 4.0 anyway.
>
> Thanks,
>
> Alexander
>

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ