Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 13 Apr 2011 04:47:30 +0400
From: Solar Designer <solar@...nwall.com>
To: owl-dev@...ts.openwall.com
Subject: Re: gcc update

Georgi,

On Wed, Apr 13, 2011 at 04:20:17AM +0400, Solar Designer wrote:
...
> or better yet you may update Owl's gcc.spec right away.  When doing the
> latter, please fully drop support for languages other than C and C++.
> (We had such support, disabled by default, in gcc.spec for years, but
> very few people ever made use of it, if any, and those who possibly did
> could as well make a custom build of gcc without our gcc.spec.)

Oh, as Owl/doc/TODO says, also drop the backwards compatibility stuff:

"Toolchain and libraries updates (gcc, glibc, OpenSSL, etc.)  Drop
pre-3.0 compatibility stuff (most notably the old libstdc++ binaries),
likely introduce new compatibility stuff to support upgrades from 3.0."

This will work for testing.  Then we'll need to see what new
compatibility stuff we might need to add for upgrades from Owl 3.0 (this
will likely be another task for you).

Thanks,

Alexander

Powered by blists - more mailing lists

Your e-mail address:

Powered by Openwall GNU/*/Linux - Powered by OpenVZ