Openwall GNU/*/Linux - a small security-enhanced Linux distro for servers
[<prev] [next>] [day] [month] [year] [list]
Date: Tue, 31 Jul 2018 07:10:59 +0000 (UTC)
From: Andrea Cosentino <ancosen1985@...oo.com>
To: Dev <dev@...el.apache.org>, Users <users@...el.apache.org>, 
	Apache Security Team <security@...che.org>, 
	"oss-security@...ts.openwall.com" <oss-security@...ts.openwall.com>, 
	"karel.jelinek@...corm.com" <karel.jelinek@...corm.com>
Subject: [SECURITY] New security advisory CVE-2018-8027 released for Apache
 Camel

A new security advisory has been released for Apache Camel, that is fixed in
the recent 2.20.4 and 2.21.1 releases:

CVE-2018-8027: Apache Camel's Core is vulnerable to XXE in XSD validation processor

The full text of the advisory is the following:

CVE-2018-8027: Apache Camel's Core is vulnerable to XXE in XSD validation processor

Severity: MEDIUM

Vendor: The Apache Software Foundation

Versions Affected: Camel 2.20.0 to 2.20.3 and Camel 2.21.0
The unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Description: Apache Camel's Core is vulnerable to XXE External Entity vulnerability XSD validation processor.

Mitigation: 2.20.x users should upgrade to 2.20.4, 2.21.0 users should upgrade to 2.21.1. 

The JIRA tickets: https://issues.apache.org/jira/browse/CAMEL-12444 and https://issues.apache.org/jira/browse/CAMEL-10894 (partial fix)
refer to the various commits that resovoled the issue, and have more details.

Credit: This issue was discovered by Karel Jelínek <karel dot jelinek at unicorn dot com> from Unicorn Systems.

On behalf of the Apache Camel PMC

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Chair
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@...oo.com
Twitter: @oscerd2
Github: oscerd

Powered by blists - more mailing lists

Your e-mail address:

Please check out the Open Source Software Security Wiki, which is counterpart to this mailing list.

Powered by Openwall GNU/*/Linux - Powered by OpenVZ